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Information in this document is subject to change without notice and does not represent a 

commitment on the part of Technical Difference, Inc. The software product described in this 

document is furnished under a license agreement or nondisclosure agreement. The software 

and this documentation may be used or copied only in accordance with the terms of that 

agreement. 

All names of companies, products, street addresses, and persons are part of a completely 

fictitious scenario and are designed solely to document the use of People-Trak. Similarities to 

real companies, products, addresses, or persons are purely coincidental. 

People-Trak is an extensively customizable HR software product. Screen and report samples 

rendered in this document reflect the default version of People-Trak. These samples may or 

may not match the screens and reports within your product if customization has been 

performed. 
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Lookup Screen 

People-Trak provides a powerful lookup feature to allow you to select the records with which 

you wish to work. The lookup feature is used whenever you need to select records for 

processing. For example, the lookup is used to select records for editing and for use in batch 

processing processes. Regardless of where or how the lookup feature is activated, it always 

works the same way. When the feature is activated, the Lookup screen is displayed, which 

has five tabs to specify what records should be selected. 

Basic Tab 
The Basic tab is used to perform simple lookups using one of four pre-defined fields. On text 

fields, you can enter a full or partial value and lookup will find all records with a value in the 

field that starts with what you entered. On non-text fields, you can enter a value and lookup 

will find all records with a value in the field that equals what you entered. The four fields 

listed can be changed to any of the fields in the module. For example, if you wish to include 

department code as one of the fields, you can add it in place of one of the other fields. Or if 

you wish to change the order of the fields, you can do so.  

Custom Tab 
The Custom tab is used to look up records when you do not know an applicable value for one 

of the fields on the Basic tab, or when you wish to create a specific query based on a single 

field. The simple query that you create is not saved. As soon as a record is selected, the query 

is discarded. 

Advanced Tab 
The Advanced tab is used to look up records when you wish to specify multiple query 

equations and/or generate complex queries. The Advanced tab uses the standard query grid. 

The query is not saved, however. As soon as a record is selected, the query is discarded. 

Favorites Tab 
If you use the Advanced tab, you may find that you are continually using the same set of 

equations to generate a lookup. Rather than keying the equation set over and over again, you 

can create a Lookup document containing a query. This document will then become one of 

your favorites and can be selected from this tab at any time.  

Options Tab 
The Options tab is used to specify the options to be used when performing the lookup. You 

can choose to span companies during the lookup and/or return only one record rather than a 

group of records. Spanning is only available to Administrators. 

Note:  If you continually use span companies on search or single record on select, you can set 

the lookup defaults for these in Module Setup. Spanning is turned off for non administrative 

users and therefore cannot be turned on in lookup for these users, even if the default is set to 

span. 
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Match Types 

Single-Record Match 
When you perform a lookup and the lookup finds/identifies a single match, the Lookup 

screen is closed and the record is returned. If you are editing records, the first screen for the 

particular module is displayed with the information for the matching record. If you are in a 

batch processing process, the pertinent information for the batch is added for the record 

selected. 

Multi-Record Match 
If the lookup returns more than one match, all of the matching records are listed including 

those that might be locked by other users. Note that the sort order for the records and the 

number of records selected are displayed in the status bar at the bottom of the screen. 

The fields listed in the selection grid are the same four fields listed on the Basic tab. If you 

change any of the four lookup fields or change the order in which they appear, the fields on 

the selection grid are changed to match. 

Sorting a List of Records 

If you used the Basic tab to perform the lookup, the list of matching records is initially sorted 

according to the field used to perform the lookup. For example, if you used Employee ID for 

the search, the records are sorted by ID. If you used Last Name for the search, the records are 

sorted by last name. If you used one of the other tabs, the records are always sorted by the 

first field on the Basic tab. 

The listed records can be sorted by any of the fields listed in the grid header by clicking on 

the grid header for that field. If you click on the first column, the records are sorted according 

to the field associated with the first column. If you click on the second column, the records 

are sorted according to the field associated with the second column. 

The order in which the records are sorted determines the order in which the records are listed 

in the Record dropdown on the Navigation Bar. Thus, if you wish to have your record group 

presented in a particular order, sort the records appropriately before selecting a record. 

Selecting a Record 

When records have been listed on the Lookup screen, you can select the record in the group 

that you wish to edit by highlighting the desired record and clicking the OK button or by 

double-clicking the row. If you selected the One Record check box in the Options tab of the 

Lookup screen, only the one record you selected is returned, otherwise the record group is 

returned. If you are editing records, the first screen for the current module is displayed with 

the information from the selected record. The Record dropdown will indicate the record ID 

and record description field (example: Full Name in Personnel Management), and the record 

counter will indicate the position of the current record in the group. For example, if after 

sorting a group of 10 records, you select record 3, the record counter will indicate “3 of 10” if 

the group was returned or “1 of 1” if you chose to only return the one record. If you are using 

a batch processing process, a line is added with the pertinent information for each record or 

just the one if only returning one record. 

Record Locks when Selecting a Record 
If you select a locked record, the “record locked” message is displayed and you can only 

select the record for display-only use. If you select a record that is not locked, but there are 
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other locked records in the selection, the record is allowed and all records are returned to the 

Record dropdown. Any locked records will be checked if and when that record is made the 

current record. 

Using the Basic Tab 

The Basic tab is used to perform simple lookups. To look up records using one of the labeled 

fields on the screen, enter a full value (or partial value on text fields) and press the ENTER 

key or click the Search button. On text fields, the search will perform a query and return all 

records with a value in the field that starts with the value entered. For example, if you enter 

the value “S” into a Last Name field on the screen, all employees whose last name starts with 

“S” are selected and displayed. In addition, the records are sorted by last name. On non-text 

fields (i.e. date, time, numeric), the search will perform a query and return all records with a 

value in the field that equals the value entered. For example, you must enter a full date into a 

date field in order for a match to be found. You cannot enter 10 for the month of October and 

find all dates that start with 10. If you need to do a partial search of non-text fields, use the 

Custom tab, which allows you to use a wide-range of operators to perform the query. 

The entries in this tab are NOT cumulative. You cannot enter a value in each field and 

assume that a more complex query will be performed. The lookup engine checks for the first 

non-blank field and then uses the entry in that field for the lookup. It does not matter if you 

have made entries in subsequent fields, or if the cursor is positioned to a different field when 

the Search button is clicked. 

Note: You can click the Search button when the cursor is positioned to one of the lookup 

fields, even if no entry has been made. The lookup will return all records in the company 

sorted by the field used to make the selection or by the first field if a value was not entered in 

any fields. If you have  

How to Change the Lookup Fields 
The fields used to perform lookups on the Basic tab are pre-defined for each module, but can 

be changed. The lookup fields are applicable to all users. The General tab within Module 

Setup can be used to select the fields that are to be used for lookup and duplicate checking in 

the current module as well as the default source for creating a record.  

Note: The Lookup fields are the same fields displayed in the grid when multiple matches are 

found. Make certain that the fields you use are sufficient to properly identify the records you 

wish to find.  

Lookup Limits 
The Lookup Limit field within User Setup is used to define the number of records to show 

when a lookup is run. The default setting for this field is 0, which means that all qualifying 

records are to be shown. Changing this setting is only required if you have a very large 

number of records in the database, which would increase the time taken for a lookup. If you 

do choose a value for the Lookup Limit that is then less than the number of qualifying records 

in a lookup, the lookup results will state that the assigned record limit has been enforced.  

Note: If you do not choose a value for the Lookup Limit and the number of qualifying 

records is greater than 5000, a Lookup Limit of 5000 is automatically enforced. 
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Using the Custom Tab 

The Custom tab is used to look up records when you do not know an applicable value for one 

of the fields on the Basic tab, or when you wish to create a specific query based on a single 

field. You can use this tab to create a simple user-defined query using the field name for the 

field you know and the value that you have. When the Custom tab is selected, the screen 

shown below is displayed.       

Queries are formed from three components: a field name, an operator, and a comparison 

value. Together, the three components form an equation of the following format. 

Field Name   Operator   Contents 

Simple Query Examples 
To select those employees that are female, enter the query shown below, with Gender as the 

Field Name, = as the Operator, and Female as the Contents.  

Gender = Female 

When this lookup query is performed, the value of the Gender field for each record will be 

compared to the value “Female”. If the Gender field contains “Female” the record is included 

in the lookup. 

To select those employees who are greater than 50 years of age, enter the query shown below. 

Age > 50 

When this lookup query is performed, the value of the Age field for each record will be 

compared to the value “50”. If the Age field contains a value greater than 50, the record is 

included in the lookup. 

To select those employees with a pay rate less than or equal to $50,000, enter the query 

shown below. 

Pay Rate <=  50000 

When this lookup query is performed, the value of the latest Pay Rate field for each record 

will be compared to the value “50000”. If the Pay Rate field contains a value less than or 

equal to 50,000, the record is included in the lookup. 

Secondary Lookup 
A secondary lookup into another module is available. For example, if you are in Safety 

Management and want to find an incident involving a certain employee but you are not sure 

of the Employee ID, you can do the following on the Custom tab of the Lookup screen: 

Using the Favorites Tab 

If you use the Advanced tab, you may find that you are continually using the same set of 

equations to generate a lookup. Rather than keying the equation set over and over again, you 

can create a Lookup document containing a query. This document will then become one of 

your favorites and will appear on the Favorites tab whenever the tab is displayed. You can 

then use that favorite to look up records anytime you like. If a favorite grows obsolete, you 

can delete the favorite using the Explorer. When the Favorites tab is selected, the screen 

shown below is displayed.  
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Note: If you find that you are using a lookup favorite more frequently than others, you can 

assign that lookup favorite to the lookup Quick Search button through User Setup. 

Creating and Saving a Favorite 
Lookup favorites are a unique type of document. They can be created using the Lookup 

Favorites option on the Documents menu and saved with a meaningful name. The meaningful 

name is displayed in the list box on the Favorites tab. 

Lookup by Favorite 
To use a Lookup Favorite in Lookup, start on the Favorites tab and highlight the desired 

favorite. Once Search has been selected, the query associated with the favorite will be 

executed and the list of matching records will be displayed. You may work with the records 

just as if they were selected by any other method. 

Using a Favorite for an Adhoc Lookup 
When a favorite is executed, the query equations from the Lookup document are moved into 

the grid on the Advanced tab. (You do not normally see these because you are positioned to 

the Favorites tab.) If you wish to make an adhoc change to the query and to select records 

again, you can do so.  

Once you select a record, the adhoc changes made on the Advanced tab are discarded. They 

are not updated to the Lookup Favorite document itself. To permanently modify the Lookup 

Favorite document, use the Lookup Favorites option on the Documents menu. 

Using the Options Tab 

The Options tab is used to span companies when looking up records and to specify if only the 

highlighted record in the search results should be opened. When the Options tab is selected, 

the following fields are displayed:  

Span Companies on Search  
Allows you to specify whether or not the current lookup should span companies. Select the 

check box to span companies. Clear the check box to not span companies, which only shows 

records from the current company. This check box is defaulted to cleared whenever a new 

lookup is started. If spanning is done, a Company column is included in the search results. If 

you prefer to have the Lookup in a module defaulted to Span Companies on Search, you can 

specify these settings in Module Setup. Spanning is turned off for non administrative users 

and therefore cannot be turned on in lookup for these users, even if the default is set to span. 

 

Note: When spanning, if you select a record from the search results that is from another 

company, you are asked if you want to switch to that other company. If you say “Yes”, you 

are automatically switched to the other company and the records from the other company (or 

just the one record if Single Record is selected) that were in the current search are opened as 

the current record group with the selected record active. This is necessary because you cannot 

edit a record from company B while in company A. The same is true if you are spanning and 

select a record from the search results that is from the current company.  Only the qualifying 

records in the current company are opened as a group (or just the one record if Single Record 

is selected).  

Single Record on Select  
Allows you to specify whether or not current lookup should only open the highlighted record 

in the search results. Select the check box to only open the highlighted record in the search 

results. Clear the check box to open all records in the search results. This check box is 
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defaulted to cleared whenever a new lookup is started. If you prefer to have the Lookup in a 

module defaulted to Single Record on Select, you can specify these settings in Module Setup. 

Editing a Record Group 

The group of records returned from a lookup can be acted upon as a group in the following 

ways.  

 Transfer a group of records from one company to another 

 Print letters, labels or other documents for the group of records 

 Email a message to each member of the group. 

 

It is also possible to remove records from the group (this does not delete them from the 

company) so that you can create the precise group you wish to work with. You can edit a 

record group using the Edit Lookup option on the File menu.  

The Edit Lookup screen contains a list of the same records contained in the Record 

dropdown. The list can be modified in two ways. You can click on each record you wish to 

keep and then click the Include button, or you can click on those records you wish to remove 

and the click the Exclude button. You can use the Include feature or the Exclude feature 

continually until the list of records matches the list you wish to use. When you click Save, 

you are returned to the workflow with the record group you indicated. You can then transfer 

the group, print documents for the group, or send email.  

If there are changes in progress in the current record, you must save those changes first before 

using Edit Lookup 

Record Locks 

People-Trak uses record locks in a multi-user environment. When a record is opened (the 

current record in a group or any single record selected), a lock is assigned to that record. The 

lock is the user name. The record locked cannot be opened for editing by any other user until 

the record is closed. A record is closed when the entire record group is closed or when 

another record becomes the current record. The record can be opened in display-only mode, 

however. If a user named “JJONES” attempts to open a record that is locked by “JSMITH”, 

the following message is displayed: 

Record in use by “JSMITH” 
Would you like to open in “display-only mode”? 

If you choose to open the locked record, you can navigate through the screens and view any 

available information. However, you cannot edit any field, or use popups anywhere within 

the available screens. 

Here are some additional record lock rules: 

 You can copy a locked record. 

 You cannot delete a locked record. 

 You cannot transfer a locked record. 

 You can print letters and labels for locked records. 

 You can send an email to a locked record, but the email cannot generate notes and 

attachments. 
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Opening an Existing Record 

Records can be opened for viewing and editing in any module using the same basic 

technique. To start the process, you can click the Open button on the Tool Bar or select the 

Open option on the File menu. The Open option starts the Lookup screen. The Lookup screen 

is used to specify the criteria for the record or records to be looked up. If the lookup generates 

a single match, the information for the record is shown on the first screen in the module. If 

the lookup generates multiple matches, the Record dropdown is also populated with all the 

records in the match. 

If a record or group of records is open when you select the Open option, that record or group 

of records will be saved and closed and then the Lookup screen will be displayed. 

Navigating Records 

Once a group of records has been returned for editing, you may navigate the list using the 

features of the Navigation Bar.  

Record Dropdown  
Performs three functions. It displays the group of records established at lookup. It also 

displays the currently selected record. Lastly, it allows you to select from any of the records 

in the group. The group is initially filled using the Lookup option and can be modified using 

the Edit Lookup feature on the File menu. 

First Record  
Selects the first record in the group of records listed in the Record dropdown. 

Previous Record  
Selects the previous record in the group of records listed in the Record dropdown. If the first 

record is the current record, the last record becomes the current record. 

Record Counter  
Indicates the position of the current record relative to the group of records listed in the 

Record dropdown. For example, the phrase “4 of 30” indicates that the fourth record in a 

group of 30 is currently displayed. This message is updated whenever the current record is 

changed using the Record dropdown itself or when any of the First, Previous, Next, or Last 

buttons are used. 

Next Record  
Selects the next record in the group of records listed in the Record dropdown. If the last 

record is the current record, the first record becomes the current record. 

Last Record  
Selects the last record in the group of records listed in the Record dropdown. 

Navigation and Record Locks 
In a multi-user environment, all navigation is subject to the record locking rules. If you are 

navigating through records using any of the available methods and the next record to be 

displayed is locked, you will encounter the “record locked” message and you will be limited 

to viewing that record in display-only mode. 
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Adding a New Record 

A record can be added to any module using the same procedure. To start the process of 

adding a record, you can click the New Record icon on the Shortcut Bar, select the New 

Record option on the File menu, or click the New Record button on the Tool Bar. You can 

add a new record with or without a record group already open. If a record group is open, the 

new record is added to the end of the group and becomes the active record ready for editing. 

Create Record Screen 
When the New Record option is selected, a Create Record screen is displayed. All modules 

will have the Source frame, which includes source fields. Some modules also have a Details 

frame, which includes detail fields as they pertain to that module. Valid record sources vary 

by module, but all modules have Copy and Template. All of the valid sources are listed 

below, with notation of the module to which they are unique. 

Copy                                  
Copies the record specified in the Source ID field to create the new record. 

Scratch                               
Creates the new record from scratch. Available in all modules except Training Administration 

and COBRA. 

Template                          
  Copies the template record specified in the Source ID field to create the new record. All of 

the data in the record template is automatically added to the new record for you, saving you a 

lot of data entry time 

Applicant                            
Copies the applicant record specified in the Source ID field to create the new record. Only 

available in the Personnel Management module. 

Employee     

Copies the employee record specified in the Source ID field to create the new record. Only 

available in the COBRA and Applicant Management module. 

Training Course                 

Copies the training course record specified in the Source ID field to create the new record. 

Only available in the Training Administration module. 

Job Table                           

Copies the job code specified in the Source ID field to create the new record. Only available 

in the Position Control and Requisition Tracking modules. 

Position                              

Copies the position record specified in the Source ID field to create the new record. Only 

available in the Requisition Tracking module. 
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Mandatory ID 

By default, there is a single mandatory field in each module. That field is the unique ID 

(employee ID, applicant ID, etc.) that identifies the record within the company. You cannot 

save a record without having specified a unique ID. If you attempt to save a new record 

without an ID, you will receive a message and you will not be able to save the record. If you 

attempt to change an existing ID to one that is in use elsewhere within the company, you will 

receive a message and the ID you have specified will be rejected. 

If you have chosen to use the Auto-Numbering feature as described below, the IDs that are 

generated will always be unique because they are checked before they are assigned. 

Auto-Numbering 

Normally when a new record is created, you will be required to provide a unique ID for the 

record. The unique ID field has a different name in each module, but it performs the same 

function. People-Trak provides a powerful Auto-Numbering feature that can be used to 

automatically assign the next available number when you first create the record. Auto-

Numbering is useful when employees are assigned sequential numbers as they are hired or 

when applicants are entered. 

The Auto-Numbering feature can be activated for any module at any time. Each company 

within the module can have its own starting number. The starting number can be restarted if 

desired. One of the powerful features provided by People-Trak is the prefix and suffix 

features. The automatically generated number can be embedded into a more complex 

numbering scheme that uses values both before and/or after the number itself. 

For example, some companies use an automatic numbering scheme for applicants that include 

the year as part of the number. You can simply assign the prefix “2007-” and all numbers will 

take the format: 2007-1, 2007-2, 2007-3, etc. In a similar way, you can assign a suffix. The 

suffix comes after the number. For example, to use the year, you would use the suffix “-

2007”. All new numbers will take the format 1-2007, 2-2007, 3-2007, etc. Finally, you can 

actually assign both a prefix and a suffix. This might be useful when you wish to have the 

prefix represent a value such as a division code and have the suffix represent a year or some 

other value. For example, to use a division code for the prefix, you would use “001-” and to 

use a year for the suffix, you would use “-2007”. All new numbers will then take the format 

001-1-2007, 001-2-2007, 001-3-2007, etc. 

Note: If you choose to use a prefix and a suffix, you may need to consider increasing the 

length of the applicable ID field. You can change the length of any field using the Field 

Customization feature. 

How Auto-Numbers are Assigned 
The Company Setup process is used to assign, maintain, and view the next available number 

for each company (within each module). When a new record is created, an attempt is made to 

assign the next available number. If the next available number has actually been used, it is not 

used because this would create a duplicate. Instead, the next sequential number is checked 

and then the next. When an available number is found, the number is used to create a new ID 

and the next available number is set to one higher than the number just used. This process is 

repeated whenever a new record is created. 

Because the Auto-Numbering feature confirms the next available number, it is possible to 

reuse the numbers from deleted or transferred records. You need only reset the starting 

number to the desired starting point. The first time that you create a new record, the search 

for an available number will begin. If a number has become available because a record was 
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deleted or transferred, the number will be available and will be assigned. The next time a new 

record is created, the next available number will be used even if it is much higher in the 

numeric sequence. Please note that there will be slight delay if many hundreds of numbers 

must be checked. 

The Auto-Numbering feature is best activated when data entry for a given company is started. 

However, if you wish to activate Auto-Numbering after records have been added, you can 

simply set the next available number to be the next number you would have assigned 

manually. If the existing records did not use sequential numbers for IDs, you can either 

renumber them or you can allow the Auto-Numbering feature to skip those numbers when 

they are reached. 

Saving a Record 

The current record including any changes in process can be saved at any time using the Save 

option on the File menu or the Save button on the Tool Bar. The Save option commits any 

changes to the database, clears the Edit History Log and all changes are shown in the 

unmodified color. Using the Save option is like closing and re-opening the record. 

Closing a Record   

If you are editing a record, you can close and save the record using the Close option on the 

File menu or the Close button on the Tool Bar. The Close option closes the current record or 

group of records and returns you to the desktop. 

Deleting a Record 

Deleting a record is a very simple process. You need only select the record and then use the 

Delete option on the File menu. The prompt shown below is displayed. 

Delete this record? 

This prompt allows you to verify that the record displayed is indeed the one you wish to 

delete. As the deletion of a record is not undoable, you should make sure before you click the 

OK button. If the record is not the one desired, click the Cancel button. 

Deleting the only record in a group causes the group to close. Deleting a record in a group of 

records causes the next record in the group to be displayed. If the record being deleted is the 

highest numbered record in the group (the last record, but not the only record), the first record 

in the group is displayed. 

Note: Records are not normally explicitly deleted on a regular basis. Deleting records is 

normally reserved for some type of mistake. Records are normally transferred from an Active 

company to some type of Archive company where they remain indefinitely. You cannot 

delete a locked record or a record that has changes that have not been saved. 

Copying a Record 

Copying a record is a very simple process. You need only select the record and then use the 

Copy option on the File menu or the Copy button on the Tool Bar. The prompt shown below 

is displayed. 

Copy this record? 
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This prompt allows you to verify that the record displayed is indeed the one you wish to 

copy. If the record is not the one desired, click the Cancel button to abandon the process. 

Otherwise, click OK to copy the record. A new record is created as a copy of the original 

record and placed at the end of the current group. The only field that is not copied is the 

unique ID field. Obviously, if the ID was copied, it would no longer be unique. You must 

specify an ID before the record can be saved. 

Note: You cannot copy a record that has changes that have not been saved. 

Transferring Records to Another Company 

The Transfer option is used to transfer a record or a group of records from the current 

company to another company. This step is normally performed when archiving records from 

the ACTIVE database to the ARCHIVE database. 

Transferring the only record in a group causes the group to close. Transferring a record in a 

group of records causes the next record in the group to be displayed. If the record being 

transferred is the highest numbered record in the group (the last record, but not the only 

record), the first record in the group is displayed.  

Note: You cannot transfer a locked record or a record that has changes that have not been 

saved. 

Running Documents 

When a record or group of records has been selected, you can use the Documents option on 

the File menu or the Documents button on the Tool Bar to run any existing documents for the 

current record or for the entire group. 

Sending Email 

When a record or group of records has been selected, you can select the Send Email option on 

the File menu or click the Send Email button on the Tool Bar to email a message to a record 

or a group of records. After the record or group option has been selected, the screen shown 

below is displayed.  

If you are sending email to a single record, the To field will contain the email address of the 

current record. If you are sending email to a group of records, the To field will contain the 

email addresses of the records in the group. 

You can complete the email by filling in the other fields on the screen. You can also send the 

email message and the attachment to the notes for each of the records specified.  

Note: If you are in a module whose key record does not have an email address associated 

with it, the Send Email option on the File menu and the Send Email button on the Tool Bar 

will be disabled. For example, if you are in the Training Course module, the key record is the 

training course, which of course is not a person that can receive an email. 

Lookup for Audit/Transaction History 

The By Record field on both the View Audit History Tab and  View Transaction History Tab 

is supported by the Lookup Employee process. 
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Lookup for Output to Email 

The Email tab is used to specify the email addresses and/or favorite lookup to be used when 

emailing the document. When the Output to Email option is used within the Document 

Viewer for this document, the Send Email screen To field is automatically filled in with the 

distribution list defined and/or the results of the lookup.   

Note: The Email tab is not available for an Export or Lookup Favorite document as there is 

no document actually produced. 
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This lesson covers how to select records for editing, how to navigate the records returned 

from the lookup process and how to edit the group of records to reflect the specific group you 

wish to see. 

Tutorials 
Selecting Records: demonstrates how to select records using full and partial entries. Also 

shows how to manipulate the group of records returned from the lookup process. 

Navigating Records: shows how to navigate through the current record group using the 

Record dropdown and the first, last, previous and next record functions. 

Edit a Record Group: demonstrates techniques for adjusting the group of records after the 

lookup has been performed. This is useful when group functions such as transfer and 

letter/label printing are to be performed and the group is not easily retrieved. 
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Tutorial 1.1 – Selecting Records 

In the Intro to PT course, you used the Lookup feature to select Donald Stern for the purpose 

of demonstrating other features in People-Trak. However, we performed the Lookup in the 

simplest manner and did not take advantage of a wide range of features. Let’s start using this 

feature more effectively now. 

1. Start People-Trak by double-clicking on the People-Trak Trainee icon on your desktop 

(or as instructed).  

 

The Select Product Option screen is displayed.  

2. The Position Control and Attendance options should be the only options that are 

toggled on. If not select the Training button to select them. 

3. Click OK  

 

The Login screen is displayed. 

4. In the User ID field, enter DEMO. 

5. In the Password field, enter DEMO. 

 

The Organizer desktop is displayed with the Personnel Management module selected. 

Let’s learn more about the Lookup feature. 

6. On the File menu, select Open Employee or on the Shortcut Bar, click Open Employee.  

 

The Lookup Employee screen is displayed because we are in the Personnel Management 

module and are looking up Employee records. The Lookup screen for each of the 

modules all behave the same, you are just looking up different record types. The Lookup 

screen provides five individual tabs for selecting records. The focus of this lesson will be 

the first tab, Basic. You will learn more about the other tabs later. 

 

The Basic tab first provides up to four separate fields that can be used to look up records. 

The actual fields can be defined by your organization. It is normally assumed that one of 

these fields is the ID (employee, application, position, etc.) and one is the Name 

(employee or applicant last name, description, title, etc.). When the Lookup screen is 

displayed, the cursor is always positioned to the first field, which we will assume is the 

Employee ID field in the Personnel Management module. We will now attempt to select 

one of the existing demonstration employees for processing.  

7. In the Employee ID field, enter 1060 and press ENTER.  

 

The following message is displayed:  

No matching records 

Why? The reason for this error is that you entered an incorrect employee ID, but it is not 

your fault. You were given an incorrect employee ID to demonstrate an important point. 

When selecting an existing employee, the employee ID entered must match an existing 

employee ID. If it does not, the program cannot retrieve the desired employee and the 

message shown above is displayed. When you see this message in the future, do not fear 
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that the desired employee has disappeared. In most cases, the message appears because 

the ID has not been entered correctly. 

8. Press ENTER to clear the message.  

9. In the Employee ID field, enter 1006 and press ENTER.  

 

The Personal screen for Donald Stern is displayed. You did not see a list of employees as 

you have in the past because you entered a direct match. There is only one record with 

the ID 1006 and when there is a direct match, People-Trak moves directly to that record. 

 

You can provide sufficient information for a direct match at any of the fields shown on 

the Basic tab. If you provide a unique last name, that record will be fetched. If you 

provide a name that is not unique, you will see a list of employees that share that name 

and you can select the particular record that you want. 

 

Now let’s learn how to use the “partial entry” method. First, we need to close the record 

we have selected. You can do this using the Close Employee or Exit option on the File 

menu, the Close Employee button on the Tool Bar, or the X in the upper right-hand 

corner of the Personal screen. So many options, so little time. Still another method, which 

will save a little work, is to directly select the Open Employee option. The Close 

Employee operation is assumed and you will proceed directly to the Lookup screen. If 

you have changes in process, they are saved. This time, let’s do the following step to 

close the record. 

10. On the File menu, select Open Employee or on the Tool Bar, click the Open Employee 

button. 

 

Donald’s record is closed and the Lookup Employee screen is displayed. 

11. In the Employee ID field, enter the single digit 1 and press ENTER.  

 

A list of those employees with ID numbers starting with 1 is displayed. On text fields, 

such as Employee ID, you can enter a full or partial value and lookup will find all records 

with a value in the field that starts with what you entered. On non-text fields (i.e. date, 

time, numeric), you can enter a value and lookup will find all records with a value in the 

field that equals what you entered. For example, you must enter a full date into a date 

field in order for a match to be found. You cannot enter 10 for the month of October and 

find all dates that start with 10. If you need to do a partial search of non-text fields, use 

the Custom tab, which allows you to use a wide-range of operators to perform the query. 

You will learn about the Custom tab in the Query and Reporting training class. 

 

Now, let’s find out how to select an employee from the list. You can select the desired 

employee in three ways. You can double-click on the desired employee, you can position 

the highlight over the desired employee and press ENTER, or you can position the 

highlight over the desired employee and click OK. Finally, if you wish to abandon the 

selection process, you can click Cancel. 

12. Let's select Donald Stern using the double-click method.  

 

The information for Donald Stern is displayed just as it was before. Now let's learn how 

to show a list of all employees in the database. 

13. On the Tool Bar, click the Open Employee button to clear the information for Donald 

Stern and move directly to the Lookup Employee screen.  
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14. This time, perform a partial lookup using S in the Last Name field.  

 

You will see a list of those employees who have a last name starting with S. 

15. Do not select an employee this time. Instead, click Clear to clear the entries so that we 

can try something else. 

16. Click Search to select all employees.  

 

When the list is displayed, note that the headings for the list are the same fields listed for 

selection. As mentioned before, up to four fields can be used for flexible lookup and to 

enable you to identify the appropriate records. If you happen to have dozens of 

employees named Smith and you cannot remember hundreds of individual employee ID 

numbers, the fields in the list assist you in determining just which Smith you wish to 

select. 

 

The list of records can also be sorted. To sort the list, click on the column header for the 

appropriate field. Try it.  

17. Sort the list by Last Name and then by each of the other fields.  

 

If you click on a header more than once, the sort order will alternate between ascending 

and descending. This feature can assist you in selection and in record navigation, which 

we will discuss next. 

18. Continue with the next tutorial.  
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Tutorial 1.2 – Navigating Records 

When you select a record from a list, the record selected becomes the current record 

displayed, but in fact, the entire list of records is returned as a group that you can work with. 

That is why features are provided to allow you to manipulate the list before selecting the 

specific record. The group of records that meet your selection criteria is added to the Record 

dropdown on the Navigation Bar. This tutorial will show you how to navigate this list. 

You should still be in the Lookup Employee screen with a list of all employees. 

1. Before selecting a record, sort the list in ascending (A to Z) order by Last Name by 

clicking on the field heading. Then select Donald Stern. 

 

Now let’s evaluate what we have. The name displayed in the Record dropdown (on the 

far left side of the Navigation Bar) should be Donald Stern, but there are other records in 

the dropdown. This is clearly indicated by the record counter (between the blue arrows) 

that shows what number Donald is with respect to the total number of records displayed.  

2. Let’s verify this by clicking on the Record dropdown and scrolling through the list of 

names. Select Frank Adams and see what happens.  

 

The current record changes to Frank Adams and the record counter changes to reflect 

Frank’s position in the list. 

3. Use this technique to return to Donald Stern.  

 

The Record dropdown can be used to select any record that has been returned from the 

Lookup process. The record ID and description are displayed. In an employee record, the 

description is the full name backward. The records are ordered in the dropdown 

according to the manner in which they were sorted in the Lookup. You will recall that we 

sorted by last name in ascending order.  

 

While the Record dropdown is used to select a specific record by name, the four blue 

buttons adjacent to the Record dropdown are used to move through the list incrementally.  

4. Using the mouse, position the cursor over each of the four blue buttons and right click to 

see the name associated with each button. 

 

The leftmost button is the First button. It will select the first record in the list as the 

current record.  

5. Click the First button.  

 

If your dropdown is still sorted by last name, the current record will become Frank 

Adams and the record counter will indicate 1 of 32, or something similar.  

 

The rightmost blue button is the Last button. It will select the last record in the list as the 

current record.  

6. Click the Last button.  

 

The current record should become Gregory Wilson, with the record number indicating he 

was the last in the group. 
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The inner buttons are used to select the previous and next records in the list. Let’s try 

these and see how they work. 

7. Click the Next button. 

 

Since you were positioned to the last record, clicking the Next button cycled you around 

to the first record.  

8. Now click the Previous button to cycle back around to the last record. 

 

You can also use key sequences to do the next record and previous record functions. 

9. Press CTRL + PAGE DOWN (hold down the CTRL key and press the PAGE DOWN 

key). 

 

The next record is displayed. 

10. Press CTRL + PAGE UP (hold down the CTRL key and press the PAGE UP key). 

 

The previous record is displayed. 

 

Record navigation is frequently used in a process known as “browsing”. From time to 

time, you may find the need to browse through a group of records to check a specific 

field or make relative comparisons. Browsing is an easy way to do that. 

11. Select the first record in the current list by clicking the First button.  

12. Use the Screen dropdown on the Category Bar to select the Compensation screen.  

 

Let’s assume that you wish to “browse” salary history for this group.  

13. Review the first record and then click the Next record button to see the next record. 

Review the second record and then the third. Continue browsing until you have seen what 

you wanted to see or you have returned to record 1.  

 

You can use this technique for any primary data entry screen and most data entry sub 

screens. 

14. Continue with the next tutorial.  
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Tutorial 1.3 – Edit a Record Group 

The group of records returned from the lookup process can be acted upon as a group. You can 

transfer records and print labels and letters for members of the group. Sometimes, however, 

the group contains one or more records that you do not want and the exact group is not easily 

retrieved. You can adjust the group to include the members you want using the Edit Lookup 

features. Here’s how. 

1. On the Tool Bar, click the Open Employee button. 

2. On the Lookup Employee screen, click Search, which returns a list of all employees 

sorted in ascending order by Employee ID. Click OK.  

 

Now let’s assume that we wish to print labels for this group, but that three of the 

employees are terminated and you do not need labels for them. 

3. On the File menu, select Edit Lookup. 

 

The Edit Lookup screen provides a list of the current members in the order in which they 

are listed in the Record dropdown. Let’s exclude the three members who are not to 

receive labels. 

4. Locate Donald Stern and select the check box adjacent to his name. Do the same for 

Frank Adams, and Penny Armstrong.  

5. Click Exclude.  

 

What happens?  The list is reduced from the original number by three members, and 

Donald, Frank, and Penny have been deleted.  

6. Click Save, which will save your changes and close the Edit Lookup screen.  

 

You are returned to the workflow with your new record group. Three from the original 

number are excluded, reducing the record counter, and the actual members in the Record 

dropdown are changed to reflect the exclusions. Your new group works exactly as if you 

had selected these employees in your initial lookup. If you realize that you need to 

exclude more members, simply use the Edit Lookup screen to exclude them. Conversely, 

if you only want a few of the records from the list, simply use the screen to include only 

those that you need. 

 

Once you have adjusted your list of employees to the precise list you desire, you can 

perform whichever group-related function you wish. Only the current members of the 

group will be affected. Let’s try one more thing.  

7. On the File menu, select Edit Lookup.  

8. This time, select any five employees, but be sure to not select the employee currently 

listed in the Record dropdown.  

9. Click Include. 

 

The list is adjusted to include only those five employees.  

10. Click Save and see what happens this time.  
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Of course, the group is adjusted and the record count is modified, but what happens to the 

current record that is no longer in the group?  You can check this yourself, but what 

happens is that the next available member of the group is selected for you. If you were on 

the last member of the group, the first member would be selected.  

 

Note: If there are changes in progress in the current record, you must save those changes 

first before using Edit Lookup. 

 

Remember how to close a record group? You have several alternatives as stated earlier in 

this lesson. You can close a record group using the Close Employee or Exit option on the 

File menu, the Close Employee button on the Tool Bar, or the X in the upper right-hand 

corner of the current screen. 

11. Close your record group using whatever method you choose.  

12. This concludes this tutorial and lesson. 
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This lesson covers how to add, transfer, delete and copy records. It also covers how to use a 

record template and view history for a record. 

Tutorials 
Add a Record: shows how to add a new record and supply a unique ID. 

Transfer a Record: demonstrates the technique for transferring a record from one company 

to another. 

Delete a Record: shows how to delete a record. 

Copy a Record: demonstrates how to copy a record. 

Use a Record Template: shows how to use a record template to create a new record. 

View History for a Record: demonstrates how to view the edit and transaction history for a 

record. 
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Tutorial 2.1 – Add a Record 

In the last lesson, we learned how to select an existing employee for processing. When an 

employee is added, there is no existing employee to select. It is necessary to add all employee 

information from scratch. The first step in adding an employee is getting a blank record and 

establishing an employee number. 

 

There are three ways to start a new employee record. You can use the New Employee option 

on the File menu, the New Employee button on the Tool Bar (when records are open), or the 

New Employee shortcut on the Shortcut Bar (when records are not open). Let’s use the 

shortcut this time. 

1. On the Shortcut Bar, click New Employee. 

 

The Create Employee screen is displayed with the Employee Source field set to Scratch. 

Let’s see what other sources are available. 

2. In the Employee Source field, click the popup button. 

 

The Select Employee Source screen is displayed. Every module has the Copy and 

Template options. All modules except Training Administration and COBRA also have 

the Scratch option. Each module might also have options that are module specific. In the 

case of the Personnel Management module, there is an Applicant source, which allows 

you to create a new employee record from applicant information. In this tutorial, we will 

create an employee record from scratch. We will learn about the Copy and Template 

options later in this lesson.  

3. Click OK to select the Scratch option. 

 

You are returned to the Create Employee screen. Unless instructed differently, whenever 

you are asked to create a new employee, simply click the Create button when you see this 

screen. 

4. Click Create to create a new employee from scratch. 

 

When the Personal screen is displayed, the cursor is positioned to the Employee ID field, 

which has a value of NEW1. If NEW1 had already existed, this value would be NEW2 

and so on. 

5. In the Employee ID field, replace NEW1 with 1006.  

 

The following message is displayed when you attempt to leave the field: 

Duplicate ID 

The reason for this error is that we directed you to enter an existing employee number. As 

you can see from this example, when specifying a new employee number, the number 

entered must not match an existing number. A new ID must be unique. That is one reason 

why some companies use the Auto-Numbering feature. 

6. Click OK or press ENTER to clear the message.  

7. Now enter an available employee number such as 2006.  

 

This value will be accepted. 
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8. Enter a few other fields and note that the fields are shown in the modified color.  

 

If you return to one of the fields, you will see that the field can be changed just as if an 

existing record were being modified. This is true because an existing record is being 

modified; it just happens to be a blank existing record. You are changing blank data to 

new data. If you undo any of the changes, the field will return to its original state, which 

is blank. 

9. On the Tool Bar, click the Close Employee button to close the record.  

 

The new record is now saved and has become part of the Active company in the training 

database. Do not worry; we will delete the record in a subsequent tutorial. 

 

You can also add a new employee when you have a record group open for editing. Let’s 

see how this works. 

10. On the Shortcut Bar, click Open Employee and then click Search and OK. 

 

All employees are opened as a record group for editing. Note how many employees have 

been returned by looking at the Record Counter in the Navigation Bar. 

11. On the Tool Bar, click the New Employee button to start a new record.  

You are returned to the Create Employee screen.  

12. Click Create to create a new employee from scratch. 

 

A record with an Employee ID of NEW1 is created.  

Let’s finish this record by showing what happens if you save a record without changing 

the ID. 

13. Leave the Employee ID as NEW1, but start filling out other fields. After a few fields, 

close the record.  

14. Use the Lookup process to open all employees for editing.  

15. Select the NEW1 employee.  

As you can see, the record has been saved with the Employee ID of NEW1. 

Before closing this record group, we want to check one last thing. Take a look at the 

Record Counter in the Navigation Bar. Notice that this new record has been added to the 

record group. For example, if the counter said 1 of 33 before, it should now say 34 of 34 

because the new record has been added at the end of the group and is now the active one. 

16. On the Tool Bar, click the Close Employee button to close the record. We will delete this 

employee in a later tutorial. 

17. Continue with the next tutorial. 
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Tutorial 2.2 – Transfer a Record 

People-Trak is a multi-company product. This means that you can track employee and 

applicant records in multiple separate companies. For most organizations, there will be an 

Active company that contains active records and an Archive company that contains obsolete 

or non-active records. This tutorial will show you how to transfer records between 

companies. All of the companies will be maintained in just one database. 

You can only transfer an employee when editing an employee record or group. First, let’s see 

how a transfer works with a group. 

1. Use the Lookup process to open all employees for editing. 

2. Select the employee with an Employee ID of 2006.  

 

Make note of the Record Counter in the Navigation Bar. 

3. On the File menu, select Transfer Employee.  

 

The Transfer screen is displayed. 

4. In the Transfer Type field, click the popup button. 

 

The Transfer Type screen is displayed, which lists two options. The Current Record 

option is used to transfer the current employee. The Current Group option is used to 

transfer all of the records in the group.  

5. The Current Record option should already be highlighted, so click OK to select that. 

6. In the Transfer To field, click the popup button. 

 

A list of the companies to which you have access is displayed, not including the current 

company. 

7. The ARCHIVE company should already be highlighted, so click OK to select that. 

8. Click Transfer to perform the transfer. 

 

First, let’s look at what happened to the Record Counter. You should see that it has 

changed. For example, if the 2006 record was 30 of 34, the counter would now say 30 of 

33 and be showing the record that was the next record in the group. If the 2006 record 

was 34 of 34, the counter would now say 1 of 33. Transferring a record in a group of 

records causes the next record in the group to be displayed. If the record being transferred 

is the highest numbered record in the group (the last record, but not the only record), the 

first record in the group is displayed. 

 

The transfer process is a move and not a copy. Thus, the record has been deleted from the 

ACTIVE company and now exists only in the ARCHIVE company. Let’s prove it. 

9. Close the record group. Try to look up record 2006. You are not able to do so.  

10. On the File menu, use the Select Company option to switch to the ARCHIVE company.  

11. Now try to look up record 2006. The record you transferred will be found. Open the 

record. 
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Now, let’s transfer the record from ARCHIVE back to ACTIVE.  

12. On the File menu, select Transfer Employee.  

 

The Transfer screen is displayed. 

13. In the Transfer Type field, select Current Record. 

14. In the Transfer To field, click the popup button. 

 

The list of companies is displayed. Note that ACTIVE is shown and that ARCHIVE is 

not because you cannot transfer a record within the same company. 

15. The ACTIVE company should already be highlighted, so click OK to select that. 

16. Click Transfer to perform the transfer. 

 

Because we only had one record in the group and then transferred that record, the group 

was closed. The record is now in the ACTIVE company again and deleted from the 

ARCHIVE company. 

 

When a record transfers, everything in the record transfers. If there are dozens of 

Performance Appraisals, Compensation History, and Benefits Enrollments, they all 

transfer.  

17. On the File menu, use the Select Company option to return to the ACTIVE company. 

18. Continue with the next tutorial. 
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Tutorial 2.3 – Delete a Record 

In actuality, it is rare to delete any type of record. To completely discard information that has 

been painstakingly entered is unusual. Normally, information is transferred to some type of 

archive and left there for a long time, just in case it is needed. However, if a record really 

does need to be deleted, here is how you can do it.  

You can only delete an employee when editing an employee record or group.  

1. Use the Lookup process to only open the record with an Employee ID of 2006. 

2. On the File menu, select Delete Employee. 

 

The following message is displayed:  

Delete this employee? 

3. Click Yes to delete the employee record. 

 

Because we only had one record in the group and then deleted that record, the group was 

closed. This behaves just like the transfer did, which is really a delete itself. 

4. Try to look up record 2006. You will not be able to do so. 

5. Now use the Lookup process to open all employees for editing. 

6. Select the NEW1 employee. 

 

Make note of the Record Counter in the Navigation Bar. 

7. Now delete the NEW1 employee. 

 

What happened to the Record Counter? You should see that it has changed just like when 

the transfer was done. 

8. Close the record group. 

 

Note: For your protection, there is no obvious way to delete records in groups. The 

feature would be too dangerous. If you ever need to delete a large number of records, you 

should consult with your Support Representative. 

9. Continue with the next tutorial.  
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Tutorial 2.4 – Copy a Record 

The Copy Record function can be a big timesaver. Imagine that the roof just caved in on our 

training class (ouch!). We would have just been involved in the same incident but probably 

had a variety of injuries. We would want to create an incident that contained the information 

about the incident itself, copy that multiple times and then put in the details for each person. 

This would save you typing in the same general information over and over again. Let’s do an 

example. 

1. Switch to the Safety Management module. 

2. On the File menu, select New Incident or on the Shortcut Bar, click New Incident. 

3.  Click Create to create the record from scratch. 

4. In the Incident Description field, enter Roof Collapse. 

5. In the Incident Date field, enter today’s date. 

6. In the Incident Time field, enter the current time. 

 

You would enter more information on this and other screens about the incident itself but 

let’s save some typing and assume all that entry has now been done.  

7. On the File menu, select Save Incident. 

 

We are now ready to copy this record with the common information in it. 

8. On the File menu, select Copy Incident. 

 

The following message is displayed: 

Copy this record? 

9. Click Yes to copy the record.  

 

You will see an extracting message down in the Status Bar as the copy is being done. 

When the copy is complete, you will be in the newly created record, which has been 

placed at the end of the current group like any new record. You can see that the 

information from the original incident record has been copied to this new incident record. 

You would now add details for a specific person in this incident record. You just saved 

yourself a lot of time and effort. 

 

There is one other way to copy a record. Let’s take a look at that. 

10. On the Tool Bar, click the New Incident button. 

 

The Create Incident screen is displayed with the Incident Source field set to Scratch. We 

have always created a new record from scratch up until now. This time, we will use the 

Copy option. 

11. In the Incident Source field, select Copy. 
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12. In the Source ID field, click the popup button.  

 

The Lookup Incident screen is displayed.  

13. Click Search and select the incident record you originally created from scratch. 

 

You are returned to the Create Incident screen, and the Source ID and Description fields 

now contain the information for the record you selected. 

14. Click Create. 

 

When the copy is complete, you will be in the newly created record, which once again is 

a copy of the original incident record.  

 

You can use either method to copy records. You have lots of options! 

15. Delete all of the incident records you just created.  

16. Switch back to the Personnel Management module. 

17. Continue with the next tutorial. 
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Tutorial 2.5 – Using a Record Template 

We just saw how copying a record can save a lot of time when you have records that are 

related. Templates can be used to perform a similar purpose when there is a recurring 

commonality among records. For example, employees might all receive the same company 

property items upon hire. They might also be required to attend employee orientation 

training. There are also sometimes different groups of employees, such as admin and 

customer support, who have some additional, but different training requirements. It would be 

nice to have the common information already entered in a record that could be used as a 

template. This template can then be used to create new employee records. Let’s demonstrate 

how templates can be used. 

1. On the File menu, select New Employee or on the Tool Bar, click the New Employee 

button. Click Create to create the record from scratch. 

 

Now, we need to flag this record as a template. It is a good idea to have the Employee ID 

of a template follow a naming convention of your choice. This makes templates easily 

identifiable. In our case, we are going to use an Employee ID of Template, but it can be 

anything you desire and is not required. 

2. In the Employee ID field, enter Template. 

 

Now, we need to tell the system that this is a non-active, template record. 

3. On the File menu, select the Record Status menu option. 

 

The Record Status screen is displayed. 

4. Clear the Record Active check box because this record is a template and not active. 

5. Select the Template check box. 

6. Close the Record Status screen, saving your changes. 

 

Now, let’s enter property items that every new employee receives. 

7. Using the Screen dropdown, select the Status screen. 

8. Click the Property button. 

9. In the Property Type column, enter the following items: 

 

ID Card 

Keys 

Policy Manual 

10. Close the Company Property screen, saving your changes. 

11. Close the record, saving your change. 

 

Now, we have a template record that we can use when creating a new record. You would 

normally enter a lot of other standard information in a template, but this information is 

enough for our demonstration. 
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12. On the Tool Bar, click the New Employee button. 

 

The Create Employee screen is displayed with the Employee Source field set to Scratch. 

Now it is time to try out the Template option. 

13. In the Employee Source field, select Template. 

14. In the Source ID field, click the popup button.  

 

The Select Template screen is displayed. Since we only have one template record, it is 

the only one listed. You can create as many templates as you need. In our earlier example 

of admin versus customer support employees, you might want two templates because of 

their different training requirements. 

15. Click OK to select that template record. 

 

You are returned to the Create Employee screen, and the Source ID and Description 

fields now contain the information for the template record you selected. 

16. Click Create. 

 

When the copy is complete, you will be in the newly created record, which is a copy of 

the template record. 

17. In the newly created record, navigate to the Status screen and select the Property button. 

 

There is the information from the template. You would then enter any other information 

needed on this screen, such as the Issue Date. We won’t take time to do that. 

18. Close the Company Property screen.  

 

The new employee record has been populated with all of the data that was in the template 

record. This can be a big timesaver. 

19. Stay in this record. 

20. Continue with the next tutorial. 
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Tutorial 2.6 – View History for a Record 

People-Trak can capture three types of history for a record: Edit, Transaction and Audit. In 

this tutorial, we will view edit and transaction history.  

Whenever you change a field in a record, it is added to the Edit History log. This log enables 

you to see unsaved changes made in the current record. Let’s do a couple changes and see 

how this works. 

1. You should still be in the record that was just created by using the template.  

 

At this point, you would normally enter the data for this new employee. Let’s just enter a 

first and last name for demonstration purposes. 

2. Return to the Personal screen  

3. In the First Name field, enter John. 

4. In the Last Name field, enter Adams and press ENTER. 

5. On the Audit menu, select Edit History.  

 

You will see the changes you made with the before and after values listed.  

6. Close the Edit History screen. 

7. In the First Name field, enter James and press ENTER. 

8. On the Audit menu, select Edit History again.  

 

You will see the first change you made listed first and the change you just made listed 

second. Changes are listed in the Edit History screen in the order they were created. 

9. Close the Edit History screen. 

 

Let’s undo the last change we made.  

10. Position to the First Name field you changed.  

11. On the Edit menu, select Undo or on the Tool Bar, click the Undo button.  

 

You will see the last change you made revert back to the change before it. 

12. Select the Edit History option again.  

 

Your second change is no longer listed because it has been undone.  

13. Close the Edit History screen. 

14. On the Tool Bar, click the Save button.  

 

The change you made will go from the modified color to the normal color because the 

change has been saved to the database. 
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15. Select the Edit History option again.  

 

The following message is displayed: 

There is no edit history for this record 

This is because your change has been saved to the database. If this field was being 

audited, the Edit History log entry would have been transferred to the Audit History log 

when the record was saved. 

 

Note: The Edit History log is also cleared whenever you close a record and choose not to 

save. 

 

Now, let’s view the transaction history for this record. 

16. On the Audit menu, select the Transaction History menu option. 

 

The following message is displayed: 

There is no transaction history for this record 

Note: The Transaction History menu option can be turned off for a user by clearing the 

Transaction History check box for the Audit menu in Security Setup- Module under the 

Menu tab. 

17. Close the record. 

 

There was no transaction history for the record because transaction history is not being 

saved for the Personnel Management module. When People-Trak is shipped, all standard 

modules are set to not save transaction history, but this setting can be changed. 

 

Let’s start saving transaction history for the workflows in the Personnel Management 

module. 

18. On the Setup menu, select Module Setup.  

19. Select the General tab. 

20. Select the Save Transaction History check box in the Settings frame.  

21. Close the Module Setup screen, saving your changes.  

22. Open the record for John Adams and make a change to a couple of fields. Click the Save 

Employee button on the Tool Bar to save the changes and stay in the record. 

23. On the Audit menu, select Transaction History. 

 

The Transaction History screen is displayed showing an entry for the Standard-Employee 

workflow in the top list box and the detail for that highlighted transaction in the Changes 

grid at the bottom. These are the changes you just made and saved.  

24. Close the Transaction History screen. Make another change in the current record and 

click the Save Employee button. Then select Transaction History once again. 

 

Now you will see two transaction entries for your workflow, with the most recent 



Working with Records 

 

 Records and Lookup     33 
 

transaction on top and highlighted. You will also see the change you just made in the 

Changes grid.  

 

The transaction history for a record provides important information about what has 

happened to this record. Capturing transaction history can be extremely valuable when 

combined with an approval process.  

25. Close the Transaction History screen. 

 

We will be looking at auditing in the next lesson, but let’s take a quick look at audit 

history now to see how saving transaction history affects that as well. 

26. On the Audit menu, select Audit History. 

 

You should see the changes you just made because saving transaction history is auditing 

all fields on the workflow, whether or not those fields have been specifically set for 

auditing in Audit Setup or Screen/Field Customization.  

 

Note: The Audit History menu option can be turned off for a user by clearing the Audit 

History check box for the Audit menu in Security Setup- Module under the Menu tab. 

27. Close the Field Audit History screen and close the record. 

28. On the Setup menu, select Module Setup.  

29. Select the General tab. 

30. Clear the Save Transaction History check box in the Settings frame.  

31. Close the Module Setup screen, saving your changes.  

32. Exit People-Trak. 

33. This concludes this tutorial and lesson. 

 
 


